What’s Vulnerable › Vulnerabilities
CVE-2025-52892: EspoCRM is vulnerable to access denial through double slash in URI corrupting router cache
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-05 · updated 2026-06-17
- Weakness: CWE-444
Description
EspoCRM is a web application with a frontend designed as a single-page application and a REST API backend written in PHP. In versions 9.1.6 and below, if a user loads Espo in the browser with double slashes (e.g https://domain//#Admin) and the webserver does not strip the double slash, it can cause a corrupted Slim router's cache. This will make the instance unusable until there is a completed rebuild. This is fixed in version 9.1.7.
Affected products
- espocrm: before 9.1.7 — fixed in 9.1.7
How to fix
Upgrade to a fixed version: espocrm 9.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/espocrm/espocrm/commit/929611f317ce8892ea75873b0ab3094c0c510ff3
- https://github.com/espocrm/espocrm/security/advisories/GHSA-26x2-6wch-j8pf
Get alerted when CVE-2025-52892 or the next vulnerability affects your stack