What’s Vulnerable › Vulnerabilities
CVE-2025-52895: Frappe possibility of SQL injection due to improper validations
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-30 · updated 2026-06-17
- Weakness: CWE-89
Description
Frappe is a full-stack web application framework. Prior to versions 14.94.3 and 15.58.0, SQL injection could be achieved via a specially crafted request, which could allow malicious person to gain access to sensitive information. This issue has been patched in versions 14.94.3 and 15.58.0. There are no workarounds for this issue other than upgrading.
Affected products
- frappe: before 14.94.3; from 15.0.0 before 15.58.0 — fixed in 14.94.3, 15.58.0
How to fix
Upgrade to a fixed version: frappe 14.94.3, 15.58.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/commit/c795e351be033070174437324d74f44759a744a6
- https://github.com/frappe/frappe/commit/f0933590103c80c6393647dd0403d399e64c951c
- https://github.com/frappe/frappe/pull/31526
- https://github.com/frappe/frappe/security/advisories/GHSA-mhj8-jfhf-mcw9
Get alerted when CVE-2025-52895 or the next vulnerability affects your stack