What’s Vulnerable › Vulnerabilities
CVE-2025-52896: Frappe authenticated XSS via data import
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Frappe is a full-stack web application framework. Prior to versions 14.94.2 and 15.57.0, authenticated users could upload carefully crafted malicious files via Data Import, leading to cross-site scripting (XSS). This issue has been patched in versions 14.94.2 and 15.57.0. There are no workarounds for this issue other than upgrading.
Affected products
- frappe: before 14.94.2; from 15.0.0 before 15.57.0 — fixed in 14.94.2, 15.57.0
How to fix
Upgrade to a fixed version: frappe 14.94.2, 15.57.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/commit/152fd09de5bca16b8d299d715a1f5df6fca3866f
- https://github.com/frappe/frappe/commit/f11c53d4df745b58bd1c1c08e1634a2f5a55322a
- https://github.com/frappe/frappe/pull/31483
- https://github.com/frappe/frappe/security/advisories/GHSA-hv29-66qg-2v6p
Get alerted when CVE-2025-52896 or the next vulnerability affects your stack