What’s Vulnerable › Vulnerabilities
CVE-2025-52954: Junos OS Evolved: A low-privileged user can execute arbitrary Junos commands and modify the configuration, thereby compromising the system
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-862
Description
A Missing Authorization vulnerability in the internal virtual routing and forwarding (VRF) of Juniper Networks Junos OS Evolved allows a local, low-privileged user to gain root privileges, leading to a system compromise. Any low-privileged user with the capability to send packets over the internal VRF can execute arbitrary Junos commands and modify the configuration, and thus compromise the system. This issue affects Junos OS Evolved: * All versions before 22.2R3-S7-EVO, * from 22.4 before 22.4R3-S7-EVO, * from 23.2 before 23.2R2-S4-EVO, * from 23.4 before 23.4R2-S5-EVO, * from 24.2 before 24.2R2-S1-EVO * from 24.4 before 24.4R1-S2-EVO, 24.4R2-EVO.
Affected products
- Juniper Networks Junos OS Evolved: before 22.2; 22.2, 22.2-r1, 22.2-r1-s1, 22.2-r1-s2, 22.2-r2, 22.2-r2-s1 (+46) — fixed in 22.2
How to fix
Upgrade to a fixed version: Juniper Networks Junos OS Evolved 22.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-52954 or the next vulnerability affects your stack