What’s Vulnerable › Vulnerabilities
CVE-2025-52967
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-23 · updated 2026-06-17
- Weakness: CWE-918
Description
gateway_proxy_handler in MLflow before 3.1.0 lacks gateway_path validation.
Affected products
- mlflow/mlflow: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: mlflow/mlflow 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/mlflow/mlflow/issues/15944
- https://github.com/mlflow/mlflow/pull/15970
- https://github.com/mlflow/mlflow/releases/tag/v3.1.0
Get alerted when CVE-2025-52967 or the next vulnerability affects your stack