What’s Vulnerable › Vulnerabilities
CVE-2025-52999: jackson-core Has Potential for StackoverflowError if user parses an input file that contains very deeply nested data
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-121
Description
jackson-core contains core low-level incremental ("streaming") parser and generator abstractions used by Jackson Data Processor. In versions prior to 2.15.0, if a user parses an input file and it has deeply nested data, Jackson could end up throwing a StackoverflowError if the depth is particularly large. jackson-core 2.15.0 contains a configurable limit for how deep Jackson will traverse in an input document, defaulting to an allowable depth of 1000. jackson-core will throw a StreamConstraintsException if the limit is reached. jackson-databind also benefits from this change because it uses jackson-core to parse JSON inputs. As a workaround, users should avoid parsing input files from untrusted sources.
Affected products
- Maven Com.Fasterxml.Jackson.Core:Jackson-Core: before 2.15.0; 2.0.0, 2.0.0-RC1, 2.0.0-RC2, 2.0.0-RC3, 2.0.1, 2.0.2 (+137) — fixed in 2.15.0
- FasterXML jackson-core: before 2.15.0
How to fix
Upgrade to a fixed version: Maven Com.Fasterxml.Jackson.Core:Jackson-Core 2.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/FasterXML/jackson-core/pull/943
- https://github.com/FasterXML/jackson-core/security/advisories/GHSA-h46c-h94j-95f3
Get alerted when CVE-2025-52999 or the next vulnerability affects your stack