What’s Vulnerable › Vulnerabilities
CVE-2025-53003: Janssen Config API returns results without scope verification
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-01 · updated 2026-06-17
- Weakness: CWE-200
Description
The Janssen Project is an open-source identity and access management (IAM) platform. Prior to version 1.8.0, the Config API returns results without scope verification. This has a large internal surface attack area that exposes all sorts of information from the IDP including clients, users, scripts ..etc. This issue has been patched in version 1.8.0. A workaround for this vulnerability involves users forking and building the config api, patching it in their system following commit 92eea4d.
Affected products
- JanssenProject jans: before 1.8.0
References
- https://github.com/JanssenProject/jans/commit/92eea4d4637f1cae16ad2f07b2c16378ff3fc5f1
- https://github.com/JanssenProject/jans/issues/11575
- https://github.com/JanssenProject/jans/releases/tag/v1.8.0
- https://github.com/JanssenProject/jans/security/advisories/GHSA-373j-mhpf-84wg
- https://github.com/JanssenProject/jans/issues/11575
Get alerted when CVE-2025-53003 or the next vulnerability affects your stack