What’s Vulnerable › Vulnerabilities
CVE-2025-53005: Dataease PostgreSQL Data Source JDBC Connection Parameters Bypass Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-01 · updated 2026-06-17
- Weakness: CWE-153
Description
DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.11, there is a bypass vulnerability in Dataease's PostgreSQL Data Source JDBC Connection Parameters. The sslfactory and sslfactoryarg parameters could trigger a bypass vulnerability. This issue has been patched in version 2.10.11.
Affected products
- dataease: before 2.10.11 — fixed in 2.10.11
How to fix
Upgrade to a fixed version: dataease 2.10.11. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/security/advisories/GHSA-99c4-h4fq-r23v
- https://github.com/dataease/dataease/security/advisories/GHSA-99c4-h4fq-r23v
Get alerted when CVE-2025-53005 or the next vulnerability affects your stack