What’s Vulnerable › Vulnerabilities
CVE-2025-53014: ImageMagick has Heap Buffer Overflow in InterpretImageFilename
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-14 · updated 2026-06-17
- Weakness: CWE-125
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Versions prior to 7.1.2-0 and 6.9.13-26 have a heap buffer overflow in the `InterpretImageFilename` function. The issue stems from an off-by-one error that causes out-of-bounds memory access when processing format strings containing consecutive percent signs (`%%`). Versions 7.1.2-0 and 6.9.13-26 fix the issue.
Affected products
- ImageMagick: before 6.9.13-26; from 7.0.0-0 before 7.1.2-0 — fixed in 6.9.13-26, 7.1.2-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-26, 7.1.2-0. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-hm4x-r5hc-794f
- https://lists.debian.org/debian-lts-announce/2025/09/msg00012.html
Get alerted when CVE-2025-53014 or the next vulnerability affects your stack