What’s Vulnerable › Vulnerabilities
CVE-2025-53020: Apache HTTP Server: HTTP/2 DoS by Memory Increase
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-401
Description
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.
Affected products
- Apache HTTP Server: from 2.4.17 before 2.4.64 — fixed in 2.4.64
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.64. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/07/10/10
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html
Get alerted when CVE-2025-53020 or the next vulnerability affects your stack