What’s Vulnerable › Vulnerabilities
CVE-2025-5305: Password Reset with Code < 0.0.17 - Insecure Password Reset Code Creation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-18 · updated 2026-06-17
Description
The Password Reset with Code for WordPress REST API WordPress plugin before 0.0.17 does not use cryptographically sound algorithms to generate OTP codes, potentially leading to account takeovers.
Affected products
- Password Reset with Code for WordPress REST API: before 0.0.17 — fixed in 0.0.17
How to fix
Upgrade to a fixed version: Password Reset with Code for WordPress REST API 0.0.17. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dcf5c003-91b0-4e7d-89f3-7459d8f01153/
- https://wpscan.com/vulnerability/dcf5c003-91b0-4e7d-89f3-7459d8f01153/
Get alerted when CVE-2025-5305 or the next vulnerability affects your stack