What’s Vulnerable › Vulnerabilities
CVE-2025-5309: Remote Support & Privileged Remote Access server side template injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-16 · updated 2026-06-17
- Weakness: CWE-94
Description
The chat feature within Remote Support (RS) and Privileged Remote Access (PRA) is vulnerable to a Server-Side Template Injection vulnerability which can lead to remote code execution.
Affected products
- BeyondTrust Privileged Remote Access: from 24.2.2 through 24.2.4; from 24.3.1 before 24.3.4; 25.1.1 — fixed in 24.3.4
- BeyondTrust Remote Support: from 24.2.2 through 24.2.4; from 24.3.1 before 24.3.4; 25.1.1 — fixed in 24.3.4
How to fix
Upgrade to a fixed version: BeyondTrust Privileged Remote Access 24.3.4; BeyondTrust Remote Support 24.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-5309 or the next vulnerability affects your stack