What’s Vulnerable › Vulnerabilities
CVE-2025-53092: Strapi core vulnerable to sensitive data exposure via CORS misconfiguration
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-16 · updated 2026-10-19
- Weakness: CWE-200
Description
Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.
Affected products
- strapi: before 5.20.0 — fixed in 5.20.0
How to fix
Upgrade to a fixed version: strapi 5.20.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-53092 or the next vulnerability affects your stack