What’s Vulnerable › Vulnerabilities
CVE-2025-53099: Sentry Missing Invalidation of Authorization Codes During OAuth Exchange and Revocation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-01 · updated 2026-06-17
- Weakness: CWE-288
Description
Sentry is a developer-first error tracking and performance monitoring tool. Prior to version 25.5.0, an attacker with a malicious OAuth application registered with Sentry can take advantage of a race condition and improper handling of authorization code within Sentry to maintain persistence to a user's account. With a specially timed requests and redirect flows, an attacker could generate multiple authorization codes that could be used to exchange for access and refresh tokens. This was possible even after de-authorizing the particular application. This issue has been patched in version 25.5.0. Self-hosted Sentry users should upgrade to version 25.5.0 or higher. Sentry SaaS users do not need to take any action.
Affected products
- getsentry sentry: before 25.5.0 — fixed in 25.5.0
How to fix
Upgrade to a fixed version: getsentry sentry 25.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/sentry/commit/57f0129e1e977b76fe8d16667a586578791a3dcd
- https://github.com/getsentry/sentry/commit/ab5fd932ca6bd46529ba3308b4669e3cee719b8f
- https://github.com/getsentry/sentry/commit/e6241254aead969e6c8490a81cde9a01335df19d
- https://github.com/getsentry/sentry/pull/85570
- https://github.com/getsentry/sentry/pull/85571
- https://github.com/getsentry/sentry/pull/86069
- https://github.com/getsentry/sentry/pull/86532
- https://github.com/getsentry/sentry/security/advisories/GHSA-mgh8-h4xc-pfmj
Get alerted when CVE-2025-53099 or the next vulnerability affects your stack