What’s Vulnerable › Vulnerabilities
CVE-2025-53101: ImageMagick has Stack Buffer Overflow in image.c
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-14 · updated 2026-06-17
- Weakness: CWE-124
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions prior to 7.1.2-0 and 6.9.13-26, in ImageMagick's `magick mogrify` command, specifying multiple consecutive `%d` format specifiers in a filename template causes internal pointer arithmetic to generate an address below the beginning of the stack buffer, resulting in a stack overflow through `vsnprintf()`. Versions 7.1.2-0 and 6.9.13-26 fix the issue.
Affected products
- ImageMagick: before 6.9.13-26; from 7.0.0-0 before 7.1.2-0 — fixed in 6.9.13-26, 7.1.2-0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-26, 7.1.2-0. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/66dc8f51c11b0ae1f1cdeacd381c3e9a4de69774
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qh3h-j545-h8c9
- https://lists.debian.org/debian-lts-announce/2025/09/msg00012.html
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-qh3h-j545-h8c9
Get alerted when CVE-2025-53101 or the next vulnerability affects your stack