What’s Vulnerable › Vulnerabilities
CVE-2025-53106: Graylog vulnerable to privilege escalation through API tokens
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-02 · updated 2026-06-17
- Weakness: CWE-285
Description
Graylog is a free and open log management platform. In versions 6.2.0 to before 6.2.4 and 6.3.0-alpha.1 to before 6.3.0-rc.2, Graylog users can gain elevated privileges by creating and using API tokens for the local Administrator or any other user for whom the malicious user knows the ID. For the attack to succeed, the attacker needs a user account in Graylog. They can then proceed to issue hand-crafted requests to the Graylog REST API and exploit a weak permission check for token creation. This issue has been patched in versions 6.2.4 and 6.3.0-rc.2. A workaround involves disabling the respective configuration found in System > Configuration > Users > "Allow users to create personal access tokens".
Affected products
- graylog2-server: from 6.2.0 before 6.2.4; 6.3.0, 6.3.0-alpha1, 6.3.0-alpha2, 6.3.0-alpha3, 6.3.0-alpha4, 6.3.0-beta1 (+5) — fixed in 6.2.4
How to fix
Upgrade to a fixed version: graylog2-server 6.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/Graylog2/graylog2-server/commit/6936bd16a783c2944a3d2f1e83902062520f90e3
- https://github.com/Graylog2/graylog2-server/commit/9215b8f1fd32566c31e6f7447ed864df3590c157
- https://github.com/Graylog2/graylog2-server/security/advisories/GHSA-3m86-c9x3-vwm9
Get alerted when CVE-2025-53106 or the next vulnerability affects your stack