What’s Vulnerable › Vulnerabilities
CVE-2025-53110: Model Context Protocol Servers Vulnerable to Path Validation Bypass via Colliding Path Prefix
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-02 · updated 2026-06-17
- Weakness: CWE-22
Description
Model Context Protocol Servers is a collection of reference implementations for the model context protocol (MCP). Versions of Filesystem prior to 0.6.4 or 2025.7.01 could allow access to unintended files in cases where the prefix matches an allowed directory. Users are advised to upgrade to 0.6.4 or 2025.7.01 resolve.
Affected products
- modelcontextprotocol servers: before 0.6.4; before 2025.7.01
References
- https://github.com/modelcontextprotocol/servers/commit/cc99bdabdcad93a58877c5f3ab20e21d4394423d
- https://github.com/modelcontextprotocol/servers/security/advisories/GHSA-hc55-p739-j48w
Get alerted when CVE-2025-53110 or the next vulnerability affects your stack