What’s Vulnerable › Vulnerabilities

CVE-2025-53121: Stored XSS in multiple 33.0.8files in opennms/opennms

Description

Multiple stored XSS were found on different nodes with unsanitized parameters in OpenMNS Horizon 33.0.8 and versions earlier than 33.1.6 on multiple platforms that allow an attacker to store on database and then inject HTML and/or Javascript on the page. The solution is to upgrade to Horizon 33.1.6, 33.1.7 or Meridian 2024.2.6, 2024.2.7 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Fábio Tomé for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: The OpenNMS Group Horizon 33.1.7, 33.1.6; The OpenNMS Group Meridian 2024.2.7, 2024.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-53121 or the next vulnerability affects your stack