What’s Vulnerable › Vulnerabilities

CVE-2025-5315: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.2 before 17.11.5, 18.0 before 18.0.3, and 18.1 before 18.1.1 that could have allowed authenticated users with Guest role permissions to add child items to incident work items by sending crafted API requests that bypassed UI-enforced role restrictions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.11.5, 18.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-5315 or the next vulnerability affects your stack