What’s Vulnerable › Vulnerabilities
CVE-2025-53367: DjVuLibre OOB-Write Vulnerability in MMRDecoder
- Severity: high (CVSS 8.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-03 · updated 2026-06-17
- Weakness: CWE-125
Description
DjVuLibre is a GPL implementation of DjVu, a web-centric format for distributing documents and images. Prior to version 3.5.29, the MMRDecoder::scanruns method is affected by an OOB-write vulnerability, because it does not check that the xr pointer stays within the bounds of the allocated buffer. This can lead to writes beyond the allocated memory, resulting in a heap corruption condition. An out-of-bounds read with pr is also possible for the same reason. This issue has been patched in version 3.5.29.
Affected products
- DjvuNet DjVuLibre: before 3.5.29
References
- https://github.blog/security/vulnerability-research/cve-2025-53367-an-exploitable-out-of-bounds-write-in-djvulibre
- https://github.com/github/securitylab/tree/main/SecurityExploits/DjVuLibre/MMRDecoder_scanruns_CVE-2025-53367
- https://securitylab.github.com/advisories/GHSL-2025-055_DjVuLibre/
- https://sourceforge.net/p/djvu/djvulibre-git/ci/33f645196593d70bd5e37f55b63886c31c82c3da
- https://www.openwall.com/lists/oss-security/2025/07/03/1
- http://www.openwall.com/lists/oss-security/2025/07/03/1
- http://www.openwall.com/lists/oss-security/2025/07/18/3
- https://lists.debian.org/debian-lts-announce/2025/07/msg00007.html
- https://github.blog/security/vulnerability-research/cve-2025-53367-an-exploitable-out-of-bounds-write-in-djvulibre/
Get alerted when CVE-2025-53367 or the next vulnerability affects your stack