What’s Vulnerable › Vulnerabilities
CVE-2025-53368: Citizen is vulnerable to stored XSS attack in the legacy search bar
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. From versions 1.9.4 to before 3.4.0, page descriptions are inserted into raw HTML without proper sanitization by the Citizen skin when using the old search bar. Any user with page editing privileges can insert cross-site scripting (XSS) payloads into the DOM for other users who are searching for specific pages. This issue has been patched in version 3.4.0.
Affected products
- StarCitizenTools mediawiki-skins-Citizen: from 1.9.4 before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: StarCitizenTools mediawiki-skins-Citizen 3.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/aedbceb3380bb48db6b59e272fc187529c71c8ca
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/releases/tag/v3.4.0
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-rq6g-6g94-jfr4
Get alerted when CVE-2025-53368 or the next vulnerability affects your stack