What’s Vulnerable › Vulnerabilities
CVE-2025-5337: Slider, Gallery, and Carousel by MetaSlider <= 3.98.0 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via aria-label Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Slider, Gallery, and Carousel by MetaSlider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘aria-label’ parameter in all versions up to, and including, 3.98.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- metaslider Slider, Gallery, and Carousel by MetaSlider – Image Slider, Video Slider: before 3.99.0 — fixed in 3.99.0
How to fix
Upgrade to a fixed version: metaslider Slider, Gallery, and Carousel by MetaSlider – Image Slider, Video Slider 3.99.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ml-slider/tags/3.98.0/assets/metaslider/script.js#L11
- https://plugins.trac.wordpress.org/changeset/3309932/ml-slider/tags/3.99.0/assets/metaslider/script.js
- https://wordpress.org/plugins/ml-slider/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0e6492e5-a506-4d77-96d2-08f700b6ee76?source=cve
Get alerted when CVE-2025-5337 or the next vulnerability affects your stack