What’s Vulnerable › Vulnerabilities
CVE-2025-53399
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-01 · updated 2026-07-21
- Weakness: CWE-346
Description
In Sipwise rtpengine before 13.4.1.1, an origin-validation error in the endpoint-learning logic of the media-relay core allows remote attackers to inject or intercept RTP/SRTP media streams via RTP packets (except when the relay is configured for strict source and learning disabled). Version 13.4.1.1 fixes the heuristic mode by limiting exposure to the first five packets, and introduces a recrypt flag that fully prevents SRTP attacks when both mitigations are enabled.
Affected products
- Sipwise rtpengine: before 13.4.1.1 — fixed in 13.4.1.1
How to fix
Upgrade to a fixed version: Sipwise rtpengine 13.4.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/EnableSecurity/advisories/tree/master/ES2025-01-rtpengine-improper-behavior-bleed-inject
- https://github.com/sipwise/rtpengine/commits/rfuchs/security/
- https://github.com/sipwise/rtpengine/releases/tag/mr13.4.1.1
- https://www.openwall.com/lists/oss-security/2025/07/31/1
- http://seclists.org/fulldisclosure/2025/Aug/1
- http://www.openwall.com/lists/oss-security/2025/07/31/1
- https://lists.debian.org/debian-lts-announce/2026/07/msg00033.html
Get alerted when CVE-2025-53399 or the next vulnerability affects your stack