What’s Vulnerable › Vulnerabilities
CVE-2025-53470: Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-10 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds Read vulnerability in Apache NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver. This issue affects Apache NimBLE: through 1.8. This issue requires a broken or bogus Bluetooth controller and thus severity is considered low. Users are recommended to upgrade to version 1.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/b973df0c6cf7b30efbf8eb2cafdc1ee843464b76
- https://lists.apache.org/thread/32sm0944dyod4sdql77stgyw9xb2msc0
- http://www.openwall.com/lists/oss-security/2026/01/08/2
Get alerted when CVE-2025-53470 or the next vulnerability affects your stack