What’s Vulnerable › Vulnerabilities
CVE-2025-53478: CheckUser: Reflected Cross-Site Scripting (XSS) in Special:Investigate via unsanitized i18n messages
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The CheckUser extension’s Special:Investigate interface is vulnerable to reflected XSS due to improper escaping of certain internationalized system messages rendered on the “IPs and User agents” tab. This issue affects Mediawiki - CheckUser extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.
Affected products
- Wikimedia Foundation Mediawiki - CheckUser extension: from 1.39.x before 1.39.13; from 1.42.x before 1.42.7; from 1.43.x before 1.43.2 — fixed in 1.39.13, 1.42.7, 1.43.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - CheckUser extension 1.39.13, 1.42.7, 1.43.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/I3a1e21b6800ff4d813a33ee9fe9b7ccf070b6b2e
- https://phabricator.wikimedia.org/T394692
Get alerted when CVE-2025-53478 or the next vulnerability affects your stack