What’s Vulnerable › Vulnerabilities
CVE-2025-53483: SecurePoll: Multiple admin actions vulnerable to Cross-Site Request Forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-06-17
- Weakness: CWE-352
Description
ArchivePage.php, UnarchivePage.php, and VoterEligibilityPage#executeClear() do not validate request methods or CSRF tokens, allowing attackers to trigger sensitive actions if an admin visits a malicious site. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.
Affected products
- Wikimedia Foundation Mediawiki - SecurePoll extension: from 1.39.x before 1.39.13; from 1.42.x before 1.42.7; from 1.43.x before 1.43.2 — fixed in 1.39.13, 1.42.7, 1.43.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - SecurePoll extension 1.39.13, 1.42.7, 1.43.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/1149618
- https://gerrit.wikimedia.org/r/1149664
- https://phabricator.wikimedia.org/T392341
Get alerted when CVE-2025-53483 or the next vulnerability affects your stack