What’s Vulnerable › Vulnerabilities
CVE-2025-53487: ApprovedRevs: Stored Cross-Site Scripting (XSS) via unsanitized system messages
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The ApprovedRevs extension for MediaWiki is vulnerable to stored XSS in multiple locations where system messages are inserted into raw HTML without proper escaping. Attackers can exploit this by injecting JavaScript payloads via the uselang=x-xss language override, which causes crafted message keys to be rendered unescaped. This issue affects Mediawiki - ApprovedRevs extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.
Affected products
- Wikimedia Foundation Mediawiki - ApprovedRevs extension: from 1.39.x before 1.39.13; from 1.42.x before 1.42.7; from 1.43.x before 1.43.2 — fixed in 1.39.13, 1.42.7, 1.43.2
How to fix
Upgrade to a fixed version: Wikimedia Foundation Mediawiki - ApprovedRevs extension 1.39.13, 1.42.7, 1.43.2. Check the vendor advisory for mitigations.
References
- https://gerrit.wikimedia.org/r/q/Ifcab085111e7898da485a5e2ae287fee4e6d167b
- https://phabricator.wikimedia.org/T394383
Get alerted when CVE-2025-53487 or the next vulnerability affects your stack