What’s Vulnerable › Vulnerabilities
CVE-2025-53528: Cadwyn is vulnerable to an XSS attack through its docs page
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the "/docs" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.
Affected products
- zmievsa cadwyn: before 5.4.3
References
- https://github.com/zmievsa/cadwyn/commit/b424ecd57cd8dabbc8fe39b8f8ccafea629c7728
- https://github.com/zmievsa/cadwyn/security/advisories/GHSA-2gxp-6r36-m97r
Get alerted when CVE-2025-53528 or the next vulnerability affects your stack