What’s Vulnerable › Vulnerabilities
CVE-2025-53543: Kestra allows Stored XSS before 0.22
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Kestra is an event-driven orchestration platform. The error message in execution "Overview" tab is vulnerable to stored XSS due to improper handling of HTTP response received. This vulnerability is fixed in 0.22.0.
Affected products
- kestra-io kestra: before 0.22.0
References
Get alerted when CVE-2025-53543 or the next vulnerability affects your stack