What’s Vulnerable › Vulnerabilities
CVE-2025-53548: @clerk/backend Performs Insufficient Verification of Data Authenticity
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-09 · updated 2026-06-17
- Weakness: CWE-345
Description
Clerk helps developers build user management. Applications that use the verifyWebhook() helper to verify incoming Clerk webhooks are susceptible to accepting improperly signed webhook events. The issue was resolved in @clerk/backend 2.4.0.
Affected products
- clerk javascript: before 2.4.0
References
Get alerted when CVE-2025-53548 or the next vulnerability affects your stack