What’s Vulnerable › Vulnerabilities
CVE-2025-53594: Qfinder Pro, Qsync, QVPN
- Severity: medium (CVSS 4.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-02 · updated 2026-10-14
- Weakness: CWE-22
Description
A path traversal vulnerability has been reported to affect several product versions. If a local attacker gains a user account, they can then exploit the vulnerability to read the contents of unexpected files or system data. We have already fixed the vulnerability in the following versions: Qfinder Pro Mac 7.13.0 and later Qsync for Mac 5.1.5 and later QVPN Device Client for Mac 2.2.8 and later
Affected products
- QNAP Systems Inc. Qfinder Pro Mac: from 7.13.x before 7.13.0 — fixed in 7.13.0
- QNAP Systems Inc. Qsync for Mac: from 5.1.x before 5.1.5 — fixed in 5.1.5
- QNAP Systems Inc. QVPN Device Client for Mac: from 2.2.x before 2.2.8 — fixed in 2.2.8
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Qfinder Pro Mac 7.13.0; QNAP Systems Inc. Qsync for Mac 5.1.5; QNAP Systems Inc. QVPN Device Client for Mac 2.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-53594 or the next vulnerability affects your stack