What’s Vulnerable › Vulnerabilities
CVE-2025-53623: Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class
- Severity: high (CVSS 8.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-14 · updated 2026-06-17
- Weakness: CWE-78
Description
The Job Iteration API is an an extension for ActiveJob that make jobs interruptible and resumable Versions prior to 1.11.0 have an arbitrary code execution vulnerability in the `CsvEnumerator` class. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. The issue is fixed in versions `1.11.0` and above. Users can mitigate the risk by avoiding the use of untrusted input in the `CsvEnumerator` class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid using the `count_of_rows_in_file` method with untrusted CSV filenames.
Affected products
- Shopify job-iteration: before 1.11.0
References
- https://github.com/Shopify/job-iteration/commit/1a7adfdd041105a5e45e774cadc6b973a292ba55
- https://github.com/Shopify/job-iteration/pull/595
- https://github.com/Shopify/job-iteration/releases/tag/v1.11.0
- https://github.com/Shopify/job-iteration/security/advisories/GHSA-6qjf-g333-pv38
Get alerted when CVE-2025-53623 or the next vulnerability affects your stack