What’s Vulnerable › Vulnerabilities
CVE-2025-53628: cpp-httplib does not limit the length of a line
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-10 · updated 2026-06-17
- Weakness: CWE-770
Description
cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. Prior to 0.20.1, cpp-httplib does not have a limit for a unique line, permitting an attacker to explore this to allocate memory arbitrarily. This vulnerability is fixed in 0.20.1. NOTE: This vulnerability is related to CVE-2025-53629.
Affected products
- yhirose cpp-httplib: before 0.20.1 — fixed in 0.20.1
How to fix
Upgrade to a fixed version: yhirose cpp-httplib 0.20.1. Check the vendor advisory for mitigations.
References
- https://github.com/yhirose/cpp-httplib/commit/7b752106ac42bd5b907793950d9125a0972c8e8e
- https://github.com/yhirose/cpp-httplib/security/advisories/GHSA-j6p8-779x-p5pw
- https://github.com/yhirose/cpp-httplib/security/advisories/GHSA-qjmq-h3cc-qv6w
- https://github.com/yhirose/cpp-httplib/security/advisories/GHSA-j6p8-779x-p5pw
Get alerted when CVE-2025-53628 or the next vulnerability affects your stack