What’s Vulnerable › Vulnerabilities
CVE-2025-53638: Solady lacks extcodesize validation on implementation in ERC4337Factory
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-17 · updated 2026-06-17
- Weakness: CWE-754
Description
Solady is software that provides Solidity snippets with APIs. Starting in version 0.0.125 and prior to version 0.1.24, when an account is deployed via a proxy, using regular Solidity to call its initialization function may result in a silent failure, if the initialization function does not return a `bool` or some other return data. This is because regular Solidity uses `extcodesize(proxy)` to decide if call succeeds. This is insufficient in the case when the proxy points to an empty implementation. Users should upgrade to Solady v0.1.24 or later to receive a patch. Deploy any affected implementations and their factories on new EVM chains as soon as possible.
Affected products
- Vectorized solady: from 0.0.125, < 0.1.24
References
- https://github.com/Vectorized/solady/releases/tag/v0.1.24
- https://github.com/Vectorized/solady/security/advisories/GHSA-8xvx-4mvg-m9v8
Get alerted when CVE-2025-53638 or the next vulnerability affects your stack