What’s Vulnerable › Vulnerabilities
CVE-2025-53640: Indico vulnerable to user enumeration via API endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-14 · updated 2026-06-17
- Weakness: CWE-200
Description
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Starting in version 2.2 and prior to version 3.3.7, an endpoint used to display details of users listed in certain fields (such as ACLs) could be misused to dump basic user details (such as name, affiliation and email) in bulk. Version 3.3.7 fixes the issue. Owners of instances that allow everyone to create a user account, who wish to truly restrict access to these user details, should consider restricting user search to managers. As a workaround, it is possible to restrict access to the affected endpoints (e.g. in the webserver config), but doing so would break certain form fields which could no longer show the details of the users listed in those fields, so upgrading instead is highly recommended.
Affected products
- indico: from 2.2 before 3.3.7 — fixed in 3.3.7
How to fix
Upgrade to a fixed version: indico 3.3.7. Check the vendor advisory for mitigations.
References
- https://docs.getindico.io/en/stable/config/settings/#ALLOW_PUBLIC_USER_SEARCH
- https://docs.getindico.io/en/stable/installation/upgrade
- https://github.com/indico/indico/releases/tag/v3.3.7
- https://github.com/indico/indico/security/advisories/GHSA-q28v-664f-q6wj
- https://www.vicarius.io/vsociety/posts/cve202553640-detect-indico-vulnerability
- https://www.vicarius.io/vsociety/posts/cve202553640-mitigate-indico-vulnerability
Get alerted when CVE-2025-53640 or the next vulnerability affects your stack