What’s Vulnerable › Vulnerabilities
CVE-2025-53641: Postiz allows header mutation in middleware facilitates resulting in SSRF
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-918
Description
Postiz is an AI social media scheduling tool. From 1.45.1 to 1.62.3, the Postiz frontend application allows an attacker to inject arbitrary HTTP headers into the middleware pipeline. This flaw enables a server-side request forgery (SSRF) condition, which can be exploited to initiate unauthorized outbound requests from the server hosting the Postiz application. This vulnerability is fixed in 1.62.3.
Affected products
- gitroomhq postiz-app: from 1.45.1, < 1.62.3
References
- https://github.com/gitroomhq/postiz-app/commit/65eca0e2f22155b43c78724ca43617ee52e42753
- https://github.com/gitroomhq/postiz-app/security/advisories/GHSA-48c8-25jq-m55f
Get alerted when CVE-2025-53641 or the next vulnerability affects your stack