What’s Vulnerable › Vulnerabilities
CVE-2025-53648: Apache Gravitino: SQL misconfiguration can access or truncate files
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-09-29
- Weakness: CWE-89
Description
SQL misconfiguration in the Gravitino UI, in versions 1.0.0 and below, can allow a malicious user to read or truncate files. Users are recommended to upgrade to version 1.0.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache Gravitino: from 0.5.0 before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Gravitino 1.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/s0hytcv17z52dwp5dojjjwgrtqtyh2xk
- http://www.openwall.com/lists/oss-security/2026/06/30/2
Get alerted when CVE-2025-53648 or the next vulnerability affects your stack