What’s Vulnerable › Vulnerabilities

CVE-2025-53689: Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons

Description

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Jackrabbit 2.20.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-53689 or the next vulnerability affects your stack