What’s Vulnerable › Vulnerabilities
CVE-2025-53816: GHSL-2025-058 - 7-Zip Multi-byte write heap buffer overflow in NCompress::NRar5::CDecoder
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-17 · updated 2026-06-17
- Weakness: CWE-122
Description
7-Zip is a file archiver with a high compression ratio. Zeroes written outside heap buffer in RAR5 handler may lead to memory corruption and denial of service in versions of 7-Zip prior to 25.0.0. Version 25.0.0 contains a fix for the issue.
Affected products
- 7-Zip: before 25.00 — fixed in 25.00
How to fix
Upgrade to a fixed version: 7-Zip 25.00. Check the vendor advisory for mitigations.
References
- https://securitylab.github.com/advisories/GHSL-2025-058_7-Zip/
- https://www.openwall.com/lists/oss-security/2025/07/18/1
- http://www.openwall.com/lists/oss-security/2025/07/18/1
- https://lists.debian.org/debian-lts-announce/2026/05/msg00021.html
Get alerted when CVE-2025-53816 or the next vulnerability affects your stack