What’s Vulnerable › Vulnerabilities
CVE-2025-53859: NGINX ngx_mail_smtp_module vulnerability
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-13 · updated 2026-06-17
- Weakness: CWE-125
Description
NGINX Open Source and NGINX Plus have a vulnerability in the ngx_mail_smtp_module that might allow an unauthenticated attacker to over-read NGINX SMTP authentication process memory; as a result, the server side may leak arbitrary bytes sent in a request to the authentication server. This issue happens during the NGINX SMTP authentication process and requires the attacker to make preparations against the target system to extract the leaked data. The issue affects NGINX only if (1) it is built with the ngx_mail_smtp_module, (2) the smtp_auth directive is configured with method "none," and (3) the authentication server returns the "Auth-Wait" response header. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 0.7.22 before 1.29.1 — fixed in 1.29.1
- F5 NGINX Plus: r30, r31, r32, r32-p1, r32-p2, r33 (+4)
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.29.1. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000152786
- http://www.openwall.com/lists/oss-security/2025/08/13/5
Get alerted when CVE-2025-53859 or the next vulnerability affects your stack