What’s Vulnerable › Vulnerabilities
CVE-2025-53887: Directus's exact version number is exposed by the OpenAPI Spec
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-15 · updated 2026-06-17
- Weakness: CWE-200
Description
Directus is a real-time API and App dashboard for managing SQL database content. Starting in version 9.0.0 and prior to version 11.9.0, the exact Directus version number is incorrectly being used as OpenAPI Spec version this means that it is being exposed by the `/server/specs/oas` endpoint without authentication. With the exact version information a malicious attacker can look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version. Version 11.9.0 fixes the issue.
Affected products
- directus: from 9.0.0 before 11.9.0 — fixed in 11.9.0
How to fix
Upgrade to a fixed version: directus 11.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/directus/directus/commit/e74f3e4e92edc33b5f83eefb001a3d2a85af17a3
- https://github.com/directus/directus/pull/25353
- https://github.com/directus/directus/releases/tag/v11.9.0
- https://github.com/directus/directus/security/advisories/GHSA-rmjh-cf9q-pv7q
Get alerted when CVE-2025-53887 or the next vulnerability affects your stack