What’s Vulnerable › Vulnerabilities
CVE-2025-53906: Vim has path traversal issue with zip.vim and special crafted zip archives
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Vim is an open source, command line text editor. Prior to version 9.1.1551, a path traversal issue in Vim’s zip.vim plugin can allow overwriting of arbitrary files when opening specially crafted zip archives. Impact is low because this exploit requires direct user interaction. However, successfully exploitation can lead to overwriting sensitive files or placing executable code in privileged locations, depending on the permissions of the process editing the archive. The victim must edit such a file using Vim which will reveal the filename and the file content, a careful user may suspect some strange things going on. Successful exploitation could results in the ability to execute arbitrary commands on the underlying operating system. Version 9.1.1551 contains a patch for the vulnerability.
Affected products
- vim/vim: before 9.1.1551 — fixed in 9.1.1551
How to fix
Upgrade to a fixed version: vim/vim 9.1.1551. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/586294a04179d855c3d1d4ee5ea83931963680b8
- https://github.com/vim/vim/security/advisories/GHSA-r2fw-9cw4-mj86
- http://www.openwall.com/lists/oss-security/2025/07/15/2
- http://www.openwall.com/lists/oss-security/2026/04/01/4
- https://github.com/vim/vim/security/advisories/GHSA-r2fw-9cw4-mj86
Get alerted when CVE-2025-53906 or the next vulnerability affects your stack