What’s Vulnerable › Vulnerabilities
CVE-2025-53928: MaxKB has RCE in MCP call
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-17 · updated 2026-06-17
- Weakness: CWE-94
Description
MaxKB is an open-source AI assistant for enterprise. Prior to versions 1.10.9-lts and 2.0.0, a Remote Command Execution vulnerability exists in the MCP call. Versions 1.10.9-lts and 2.0.0 fix the issue.
Affected products
- 1Panel-dev MaxKB: before 1.10.9 — fixed in 1.10.9
How to fix
Upgrade to a fixed version: 1Panel-dev MaxKB 1.10.9. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/MaxKB/releases/tag/v2.0.0
- https://github.com/1Panel-dev/MaxKB/security/advisories/GHSA-38q2-4mm7-qf5h
Get alerted when CVE-2025-53928 or the next vulnerability affects your stack