What’s Vulnerable › Vulnerabilities
CVE-2025-53939: Kiteworks Core is vulnerable to Improper Input Validation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-29 · updated 2026-10-07
- Weakness: CWE-20
Description
Kiteworks is a private data network (PDN). Prior to version 9.1.0, improper input validation when managing roles of a shared folder could lead to unexpectedly elevate another user's permissions on the share. This issue has been patched in version 9.1.0.
Affected products
- Kiteworks Email Protection Gateway: before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: Kiteworks Email Protection Gateway 9.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-53939 or the next vulnerability affects your stack