What’s Vulnerable › Vulnerabilities
CVE-2025-54050: WordPress Responsive Addons for Elementor plugin <= 1.7.3 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CyberChimps Responsive Addons for Elementor responsive-addons-for-elementor allows Stored XSS.This issue affects Responsive Addons for Elementor: from n/a through <= 1.7.3.
Affected products
- cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: cyberchimps Responsive Addons for Elementor – Free Elementor Addons, Kits and Elementor Templates 1.7.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54050 or the next vulnerability affects your stack