What’s Vulnerable › Vulnerabilities
CVE-2025-54057: Apache SkyWalking: Stored XSS vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-27 · updated 2026-10-18
- Weakness: CWE-80
Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache SkyWalking: before 10.3.0 — fixed in 10.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache SkyWalking 10.3.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/sl2x2tx8y007x0mo746yddx2lvnv9tcr
- http://www.openwall.com/lists/oss-security/2025/11/27/1
- http://www.openwall.com/lists/oss-security/2026/04/13/3
Get alerted when CVE-2025-54057 or the next vulnerability affects your stack