What’s Vulnerable › Vulnerabilities
CVE-2025-54068: Laravel Livewire Code Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-03-20
- EPSS: 96.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-17 · updated 2026-06-17
- Weakness: CWE-94
Description
Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.
Affected products
- livewire: from 3.0.0 before 3.6.4 — fixed in 3.6.4
How to fix
Upgrade to a fixed version: livewire 3.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/livewire/livewire/commit/ef04be759da41b14d2d129e670533180a44987dc
- https://github.com/livewire/livewire/releases/tag/v3.6.4
- https://github.com/livewire/livewire/security/advisories/GHSA-29cq-5w36-x7w3
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-54068
- https://www.threathunter.ai/blog/iranian-threat-actor-tools-techniques-iocs-ioas/
Get alerted when CVE-2025-54068 or the next vulnerability affects your stack