What’s Vulnerable › Vulnerabilities
CVE-2025-54072: yt-dlp allows `--exec` command injection when using placeholder on Windows
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-22 · updated 2026-06-17
- Weakness: CWE-78
Description
yt-dlp is a feature-rich command-line audio/video downloader. In versions 2025.06.25 and below, when the --exec option is used on Windows with the default placeholder (or {}), insufficient sanitization is applied to the expanded filepath, allowing for remote code execution. This is a bypass of the mitigation for CVE-2024-22423 where the default placeholder and {} were not covered by the new escaping rules. Windows users who are unable to upgrade should avoid using --exec altogether. Instead, the --write-info-json or --dump-json options could be used, with an external script or command line consuming the JSON output. This is fixed in version 2025.07.21.
Affected products
- yt-dlp: before 2025.07.21 — fixed in 2025.07.21
How to fix
Upgrade to a fixed version: yt-dlp 2025.07.21. Check the vendor advisory for mitigations.
References
- https://github.com/yt-dlp/yt-dlp/commit/959ac99e98c3215437e573c22d64be42d361e863
- https://github.com/yt-dlp/yt-dlp/releases/tag/2025.07.21
- https://github.com/yt-dlp/yt-dlp/security/advisories/GHSA-45hg-7f49-5h56
Get alerted when CVE-2025-54072 or the next vulnerability affects your stack