What’s Vulnerable › Vulnerabilities
CVE-2025-5411: Mist Community Edition views.py tag_resources cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Mist Community Edition up to 4.7.1. It has been rated as problematic. This issue affects the function tag_resources of the file src/mist/api/tag/views.py. The manipulation of the argument tag leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.7.2 is able to address this issue. The patch is named db10ecb62ac832c1ed4924556d167efb9bc07fad. It is recommended to upgrade the affected component.
Affected products
- Mist: before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: Mist 4.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/Stolichnayer/mist-ce-xss
- https://github.com/mistio/mist-ce/releases/tag/v4.7.2
- https://github.com/mistio/mist.api/commit/db10ecb62ac832c1ed4924556d167efb9bc07fad
- https://vuldb.com/?ctiid.310751
- https://vuldb.com/?id.310751
- https://vuldb.com/?submit.583533
Get alerted when CVE-2025-5411 or the next vulnerability affects your stack