What’s Vulnerable › Vulnerabilities
CVE-2025-5412: Mist Community Edition Authentication Endpoint views.py login cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-02 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability classified as problematic has been found in Mist Community Edition up to 4.7.1. Affected is the function Login of the file src/mist/api/views.py of the component Authentication Endpoint. The manipulation of the argument return_to leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.7.2 is able to address this issue. The name of the patch is db10ecb62ac832c1ed4924556d167efb9bc07fad. It is recommended to upgrade the affected component.
Affected products
- Mist: before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: Mist 4.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/Stolichnayer/mist-ce-open-redirect
- https://github.com/mistio/mist-ce/releases/tag/v4.7.2
- https://github.com/mistio/mist.api/commit/db10ecb62ac832c1ed4924556d167efb9bc07fad
- https://vuldb.com/?ctiid.310752
- https://vuldb.com/?id.310752
- https://vuldb.com/?submit.583534
Get alerted when CVE-2025-5412 or the next vulnerability affects your stack